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CREATING A FIXED-LAYOUT 
EPUB AND PUBLISHING 
ONLINE: ADDENDUM

Lesson overview
In this lesson, you’ll learn how to create a slide-in caption using  
techniques you’ve learned throughout this book, especially building 
on skills learned in Lesson 15. Specifically, you’ll learn how to do the 
following:

•	 Set up the graphics to create this effect.

•	 Use the Layers panel to select groups and objects within groups.

•	 Create and modify a multi-state object.

•	 Create buttons within a multi-state object.

•	 Add animation to objects within the multi-state object.

This lesson will take about 30 minutes to complete. To get the lesson files 
used in this chapter, download them from the web page for this book at 
adobepress.com/InDesignCIB2023. For more information, see “Accessing 
the lesson files and Web Edition” in the Getting Started section at the 
beginning of this book.
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This embedded movie shows the slide-in caption 
effect in action. If Acrobat displays a warning that the 
file contains multimedia has been disabled, click the 
Options button and choose Trust this document. Then 
the movie with play..
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Create a slide-in caption
Following are the steps to create the slide-in caption shown at the end of Lesson 15.

1	 Open the file 15_FixedLayout-Alternate. The frame with the mission statement 
has been changed to a slide-in caption. If an alert informs you that the document 
contains media content that may not have playback controls in the Interactive 
PDF, click Continue. (We are not creating an Interactive PDF in this lesson.)

2	 Open the EPUB Interactivity Preview panel ( ), click the Play Preview 
button ( ), and then click the red triangles above the words “Our Mission” on 
the far left of the page. A text frame containing the mission statement slides in 
from the left. 

3	 Click the red triangles again; the mission statement slides back off the photo,  
and the button returns to the start position. Close the EPUB Interactivity 
Preview panel ( ).

If you want, leave the file 15_FixedLayout_Alternate.indd open for reference as 
you work.

Setting up the graphics

First, you need to change the existing objects in the mission statement to create the 
new objects that will work with the effect.

1	 Switch back to the file you’ve been working in, 15_FixedLayout.indd. 

2	 Choose File > Save As, name the file 15_FixedLayout_Slide-in.indd, and save it 
in the Lesson15 folder. 

3	 Using the Selection tool ( ), select the blue text frame that contains the mission 
statement. Open the Animation panel ( ), and click the trash can icon at the 
bottom of the panel to remove the animation. Close the Animation panel.

4	 Open the Layers panel ( ), and press Alt (Windows) or Option (macOS) 
while dragging the green square in the Layers panel from the Text layer up to 
the Buttons layer to create a copy of this object on the Buttons layer. Click the 
visibility icon ( ) of the Buttons layer to hide the layer.

5	 Select this blue text frame again (the one on the Text layer). With the Type 
tool ( ) click into the text frame, choose Edit > Select All, and press Delete. 

6	 Press the Esc key to return to the Selection tool. In the Control, Properties, or 
Swatches panel, choose [None] for Fill and Stroke.

 Note:  The clickable 
or tappable area 
is larger than the 
triangles, but they are 
the signal to the user 
that there is something 
to click or tap.

 Note:  To better view 
the interface onscreen 
or in print, the screen 
captures in this book 
reflect the Medium 
Light interface rather 
than the default setting 
of Medium Dark. In 
addition, some screen 
captures illustrate 
User Interface Scaling 
for a closer look at 
interface elements. You 
can modify interface 
settings in Preferences.
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7	 Choose Object > Content > Graphic. This converts the text frame to a graphics 
frame. Choose File > Place, select Tulip-Path.jpg, and click Open. 

8	 Select the containing frame (not the image), and drag the left handle of the frame 
to the edge of the page. Choose Object > Fitting > Content-Aware Fit. 

9	 Open the Layers panel ( ), move this object to the Graphics layer, and lock the 
Graphics layer so that you don’t change anything accidentally. 

Now you’ll change the formatting of the mission statement text and text frame.

1	 In the Layers panel, click in the far-left column next to the Buttons layer to 
restore layer visibility ( ).

2	 Using the Selection tool ( ), select the blue text frame that contains the mission 
statement. Open the Swatches panel, and click the Formatting Affects Text 
button ( ). Select Dark Gray for the text fill color ( ). Click the Formatting 
Affects Container button ( ); then select [Paper] for the fill color and [None] 
for the stroke color (it should already be [None]). Close the Swatches panel.

3	 Choose Object > Text Frame Options. In the Inset Spacing section of the 
General tab, click the Make All Settings The Same icon ( ). All values should 
change to the first setting, 30 px; if not, type this value and click OK.

4	 To make the text frame slightly smaller than the photo below,  
scale the text frame as follows: In the Control or Properties 
panel, set the reference point to the center ( ) position.  
In the Height field, click at the end of the  
current value, type –10%, and press Enter or  
Return. Change the reference point to center  
left ( ), and type 950 px in the Width field.

Now you will add the vertical text that says 
“Our mission,” which will become the button that triggers the movement of the 
caption. To save a few steps, a vertical text frame ready for you to use is on the 
pasteboard directly left of the mission statement text frame. 

5	 Hold down the spacebar, and then click and slide to the right to reveal the 
pasteboard to the left of the page. Use the Selection tool to select the text frame 
containing “Our mission.” Hold down the Shift key to constrain the movement 
to horizontal, and drag this text frame to the right side of the mission statement 
text frame. This text frame also contains an anchored vector object, the red 
double triangles, which will signal the reader to click or tap there.

6	 Choose File > Save.

 Note:  Make sure that 
Constrain Proportions is 
turned off ( ) for the 
Width and Height area.
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Creating duplicate groups

The structure of this effect is based on using duplicated groups of the same objects 
moved to different locations. Next, you’ll create those groups. 

1	 Using the Rectangle Frame tool ( ), create an empty graphics  
frame (fill and stroke color set to [None]) over the vertical text 
frame with the red double triangles. Make it a little larger so that it 
will be easy for you to see the edge and distinguish between the 
text frame and this new frame. You’ll convert this frame into the 
button that triggers the action, becoming the clickable or tappable 
area for the reader.

2	 Switch back to the Selection tool ( ), and drag across the mission 
statement text frame, the vertical text frame, and the empty frame. 
The objects below are on locked layers, so you can’t accidentally 
select them. Choose Object > Group.

3	 Choose Edit > Copy. Then choose Edit > Paste In Place two times so three copies 
of the group are placed on top of each other.

4	 Open the Layers panel and drag it off the dock so that it will stay open. You 
will use the Layers panel quite often to complete this exercise. You’ll use it to 
select the groups and to select objects within a group, so it’s more efficient to 
leave it open.

5	 Many objects now exist in the Buttons layer. To be sure you are working with the 
correct groups, we’ll isolate them on a separate layer. Create another layer and 
name it Mission.

6	 Click the open triangle to the left of the Buttons layer  
to reveal the list of objects in that layer. The top 
three groups are the groups you just pasted. You can 
confirm this by toggling their visibility ( ) off  
and on. Click one to select it, and then hold down 
the Shift key and select the other two duplicate 
groups. Drag them up to the Mission layer. Click the triangle to close the Buttons 
layer. You will be working only on the Mission layer.

7	 Click the triangle to the left of the Mission layer to  
reveal the groups. Select the first two groups by 
clicking the square next to one group, holding down 
the Shift key, and clicking the square to the right of 
another group in the Layers panel. 

8	 On the document page, drag the selected groups to the left to establish the 
starting position for this effect, as shown in the next figure. The selected groups 
should be off the page except for the vertical “Our mission” frame, which will 

 Note:  Since the “Our 
mission” frame that you 
moved onto the page in 
the previous exercise is 
on the Buttons layer, the 
empty frame that you 
draw will also be on this 
layer. You can confirm 
this by checking the 
Layers panel with the 
new empty frame 
selected.

 Tip:  Another way to 
organize groups is to 
rename them. While the 
pointing hand is active, 
triple-click the group 
name in the Layers 
panel. This enables you 
to click into the name 
and type a new name.
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serve as the button that readers click to open the caption. The filled frames 
should touch each other. Use the right and left arrow keys to nudge the groups 
into position as needed.

Creating a multi-state object

The next step is to turn the groups into object states. 

1	 In the Layers panel, select all three groups in the Mission layer by clicking the 
square to the right of one of them and then Shift-clicking the other two groups.

2	 Open the Object States panel ( ), and choose  
New State from the panel menu. For Object Name, 
type Mission Caption. The new multi-state object 
consists of three states that are identical except for 
their position. 

3	 Click each state in the Object States panel and watch 
its location as it’s also selected on the page. States 1 
and 2 are in the same position (mostly off the page), 
whereas State 3 is on the page.

4	 Now you will name the states so that it is clear  
which is which as you continue creating the effect. 
To change a name, click the state to select it, and 
then click the state name. Type a name and press 
Enter or Return. Name State 1 Begin, State 2 End, 
and State 3 Middle. Notice that the Begin and End 
states are exactly the same at the moment. You will 
add a different animation for each state. 

5	 At this point, it will be more convenient to leave the Object States panel open, 
so drag it off the dock.

Creating buttons within the multi-state object

Now you will create the buttons the reader will use to open and close the caption. 

1	 Select the Begin state in the Object States panel (one of the groups off the page). 
The objects within the state are automatically selected. With the Selection 
tool ( ), double-click the empty graphics frame on top of the “Our mission” 
text frame.

 Note:  Be sure to click 
the letters of the state 
name. The field will 
become an active field 
with the current name 
selected. You can then 
type over that name.
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2	 Open the Buttons And Forms panel ( ). Click the  
plus sign to the right of Actions, and choose Go To 
State. Name the button Begin Button. From the State 
menu, choose Middle to specify that the button shows 
the Middle state when clicked or tapped.

3	 Choose Edit > Deselect All, and click the multi-state 
object again to select it.

4	 In the Object States panel, select the End state (the 
other group off the page). Using the Selection tool, 
double-click the empty graphics frame on top of the 
“Our mission” text frame in this state.

5	 In the Buttons And Forms panel, choose Go To State for Action and then Middle 
for State. Name the button End Button. 

6	 Choose Edit > Deselect All, and click the multi-state object again to select it.

7	 In the Object States panel, select the Middle state (the group on the page). Using 
the Selection tool, double-click the empty graphics frame on top of the “Our 
mission” text frame in this state.

8	 In the Buttons And Forms panel, choose Go To State for Action, and for State 
choose End. Name the button Middle Button.

9	 Choose Edit > Deselect All, and click the multi-state object again to select it.

To summarize, the Begin button goes to the Middle state, the End button goes 
to the Middle state, and the Middle button goes to the End state. Click each of 
the states, select the button object, and double-check the settings in the Buttons 
And Forms panel.

10	Open the EPUB Interactivity Preview panel ( ), click the Play Preview button, 
and click the “Our mission” button. The caption appears. Click it again and the 
caption closes. In the next section, you will use animation to specify a smoother 
display for the caption so that it appears to slide across the page. Close the EPUB 
Interactivity Preview panel ( ), and choose File > Save.
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Adding animation to objects within the multi-state object

InDesign’s animation presets are used to create the smooth, sliding motion of 
opening and closing the caption.

1	 Make sure you still have the Middle state selected in the Object States panel. 
If not, select it again.

2	 In the Layers panel, click the triangle to open the  
Mission Caption, and then open the Middle group. 
Select the Middle Button object by clicking the 
square to the right of the name. When many objects 
are grouped together, it’s much easier to select them 
and confirm which object is selected, using the 
Layers panel rather than selecting them on the page. 
It’s important to select the objects and not the state itself. Using the Layers panel 
to select the objects also prevents you from accidentally selecting the state. If you  
select the state, you will produce a different effect. 

3	 Open the Animation panel ( ), and choose the  
Fly In From Left preset. For Event(s), make sure that 
On State Load is selected (which it should be by 
default). Click the triangle next to Properties to 
make more controls visible. For Animate, choose 
To Current Location. For Opacity, choose None.

4	 In the Layers panel, choose the object in the Middle 
state (<Our mission>) and apply the same settings 
in the Animation panel. Do the same with the third 
object (<Our mission is to provide fun...>).

5	 Open the Timing panel ( ). Make sure On State 
Load is selected in the Event menu. Shift-click all 
the objects listed. Click the Play Together button 
( ) at the bottom right.

6	 Choose Edit > Deselect All, and click the multi-state object again to select it; 
then choose the End state in the Object States panel ( ).

 Note:  After you 
change the Opacity 
setting to None, the 
Preset setting in the 
dialog changes to 
Custom (Fly In From 
Left) because you have 
changed a setting of the 
Fly In From Left preset.
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7	 In the Layers panel, click the triangle to open the  
End group, and select the End Button object. 

8	 In the Animation panel ( ), choose Fly In From 
Right from the Preset menu. For Event(s), make sure 
that On State Load is selected. Choose To Current 
Location from the Animate menu, and choose None 
from the Opacity menu.

9	 In the Layers panel, choose the object in the End state  (<Our mission>), and 
apply the same settings in the Animation panel. Do the same with the third 
object (<Our mission is to provide fun...>).

10	Open the Timing panel ( ). Make sure On State Load is selected in the Event 
menu, and Shift-click all the objects listed. Click the Play Together button ( )  
at the bottom right.

11	Open the EPUB Interactivity Preview panel ( ), click the Clear Preview 
button ( ), click the Play Preview button ( ), and then click the “Our mission” 
button. Now the caption opens with a smooth, sliding motion. Click the “Our 
mission” button again to close the caption. It also closes with the same smooth, 
sliding motion.

12	Close the EPUB Interactivity Preview panel ( ), and choose File > Save.

Congratulations! You have created a very useful and appealing slide-in caption. 
This effect can be easily modified for objects that you want to slide in and out from 
other directions.


